NAS im Selbstbau

12 04 2017

Wie vieles im Leben muss sich manche liebgewonnene Gegebenheit den Anforderungen der heutigen Zeit stellen. Durch den Kauf eines hypermodernen Curved-Fernseher, kam der Wunsch bei meiner Partnerin, endlich Film- und Musik zu streamen.
Diesem Wunsch komme ich natürlich gerne nach, denn auch mein Arbeitsrechner hat neben einer M.2 SSD Karte für das Betriebssystem auch ein Raid 10 mit 4x 1TB Festplatten eingebaut. Es rattern die Festplatten, die Lüfter heulen fröhlich bei Belastung, somit steigt die Geräuschkulisse deutlich an. Letztlich nur mit Kopfhörer wirklich erträglich…
Ein Server für das Datenmassengrab drängt sich förmlich auf  🙂

Lange rede kurzer Sinn, eine NAS (Network Attached Storage) muss her!

Eine fertige aus Produktionshallen diverser Hersteller kam daher für mich niemals in Frage.
Meine Anforderungen an die NAS sind, ein Windows Betriebssystem mit installiertem Hyper-V. Somit kann ich bei Bedarf problemlos VMs nach eigenen Bedarf hinzufügen. Obwohl es wohl bereits einen VDR im Docker Container gibt? Außerdem brauche ich einen PCIe Slot für meine SAS Karte zum Anschluß eines LTO Bandlaufwerks. Kleines ITX Board mit Gehäuse zur Aufnahme für 6x Festplatten 3,5 Zoll Formfaktor. Der NAS Rechner soll im Keller stehen ohne zusätzlichen Maus, Tastatur und Monitor Anschluss. Daher muss das Mainboard eine Remoteverwaltung mit separatem Managementnetzwerkanschluss zur Verfügung stellen. Außerdem sind 2 Netzwerkanschlüsse sinnvoll aufgrund meines belegten PCIe Slot durch den SAS Controller.
Als Arbeitsspeicher genügen mir erstmals 16GB ECC RAM. Warum ECC Speicher werden sich vielleicht der eine oder andere sich Fragen? Wenn das Board und Prozessor ECC unterstützen, sehe ich keinen Grund es nicht zu kaufen. Es gibt durchaus Markenspeicher zu einem günstigen Kurs. Hier heißt es die Angebote abzugrasen. Richtig ist, befindet sich der Fehler bereits auf dem Client wird dieser mit auf die NAS mit ECC transferiert. Da ich aber überwiegend Daten direkt auf der NAS erzeuge, bietet ECC einen Mehrwert an.

Somit blieb ich bei Microsoft Server 2016 hängen. Aktuell, schnell und mit Storage Spaces bietet das Betriebssystem genau die Anforderungen was ich suchte. Ich wollte weg von diesem statischen Hard- Software Raid Level Klump. Natürlich bieten viele Hersteller gut Raid Controller an die eine Vergrößerung der Datenkapazität dynamisch erlauben. Wieso aber extra Geld, und zwar nicht wenig, für Hardware ausgeben?

Die ausgesuchte Hardware sieht wie folgt aus:
– ASUS P10S-I mit TPM und mit ASMB8 Modul für Fernwartung
– Pentium G4400 (Skylake)
– 16 GB Kingston ECC Speicher (KVR21E15D8/8HA)
– Fortron 200W FSP200-50GSV-5K SFX-Netzteil
– Fractal Design Node 304
– 2x SanDisk Z410 SSD für Betriebssystem (Raid-1)
– diverse Kabel

Das Mainboard war über meine Recherche hinweg preislich extrem schwankend. Als der Gedanke für die NAS aufkam war der Straßenpreis bei ca. 165€ + Versand. Nach einigen Tagen stieg der Preis zwischen 180€ bis 195€ an. Durch eine Preissuchmaschine entdeckte ich zufälligerweise ein Angebot eines ebay Händlers. Dieser bot das Board für 145€ inkl. Versand an. Ein Glücksgriff J, denn nach meinem Kauf änderte der Händler den Verkaufspreis auf 190€.

Die Lieferung ging schnell und zügig. Hierzu einige Impressionen:

Alle Komponenten im Überblick

Alle Komponenten im Überblick

Mainboard, BMC und TPM Modul

Mainboard, BMC und TPM Modul

Intel G4400 Pentium und Kingston ECC RAM (2x 8GB)

Intel G4400 Pentium und Kingston ECC RAM (2x 8GB)

SanDisk SSD Z410 256GB

SanDisk SSD Z410 256GB

Fractal Design Node 304

Fractal Design Node 304

Leider ist der Mainboard USB Header nicht mit dem USB Kabel des Gehäuses konform. Das Mainboard erlaubt lediglich den Anschluß einer USB Buchse. Die zweite USB Schnittstelle liegt somit brach, hätte ASUS wahrscheinlich besser lösen können. Mich stört es nicht sonderlich, ist doch der USB Header ein USB2 Port. Mir genügt 2x USB3 auf der Rückseite des Gehäuses.

Ansonsten verlief der Zusammenbau der Komponenten ohne großartige Komplikationen. Es ist schön wenn alles genormt ist. Aufgrund meiner Auslegung für 6x SATA Geräte bietet mir das Netzteil mit 1x Floppy, 2x Festplatte und 2 x SATA zu wenig Stromanschlüsse. Mein Ziel war alle Stromanschlüsse des Netzteils zu verwenden. Also mußte ein Adapter für Floppy zu SATA und ein SATA Y-Kabel her. Kein größeres Problem, die notwendigen Adapter gibt es alle bei Amazon für einen kleinen Euro Betrag. Das SFX Netzteil läßt sich aufgrund seiner Größe nur mit zwei Schrauben im Gehäuse befestigen. Überlegte mir im Vorfeld lang ob eine Blende von SFX auf ATX Sinn macht. Nach dem verschrauben stellte sich heraus das Netzteil hängt perfekt in Position. Glücklicherweise entfällt somit die ATX Blende! Aufgrund des kleineren Formfaktors erfolgte die Verlegung der Kabel unter das Netzteil.
Das Kabelmanagement ist in den Bildern quasi nicht vorhanden J Sobald alle Komponenten Ihren Stammplatz beziehen, erfolgt die Optimierung. Mein Mainboard hat 2x FAN  und 1x CPU FAN Anschlüsse. Somit fehlt mir ein Anschluss um alle drei Gehäuselüfter anzusteuern. Auf die im Gehäuse integrierte Lüfter Steuerung verzichte ich erstmals. Daher bekommen der Lüfter zum Kühlen der Festplatten und der hintere Gehäuselüfter einen gratis Steckplatz am Mainboard. Somit bleibt der 3 Gehäuselüfter erstmals unbenutzt im Systemkonstrukt.
So, noch ein Wort zu den 6x SATA Ports des Mainboards. Das Board bietet 2x reguläre SATA Anschlüsse, bei Anschluss einer M.2 SSD Karte deaktiviert sich automatisch der graue SATA Port. Die restlichen 4 SATA Anschlüsse sind über ein miniSAS HD Kabel zu verbinden. Wer nicht lange nach der korrekten Bezeichnung suchen will, der findet bei verschiedenen Anbieter ein SFF-8643 auf 4x SATA Kabel. Dieses Kabel belastet Euer Budget mit 10-20€. Preislich ok, wer die 4 regulären SATA Kabel erwerben muss, liegt in ähnlicher Dimension.

Hier noch ein paar Bilder zum Einbau. Erst Prozessor, dann Prozessorkühler, RAM Riegel und zuletzt, falls vorhanden, TPM und BMC.
Hier etwas Hardwareporn 🙂

Intel G4400 Prozessor auf ASUS P10S-I Mainboard

Intel G4400 Prozessor auf ASUS P10S-I Mainboard

Intel Boxed Kühler mit Push Pins

Intel Boxed Kühler mit Push Pins

2x 8GB KVR21E15D8/8HA DDR4-2133 ECC DIMM

2x 8GB KVR21E15D8/8HA DDR4-2133 ECC DIMM

Gehäuse blank

Gehäuse blank

200 Watt Fortron FSP200-50GSV-5K Netzteil eingebaut

200 Watt Fortron FSP200-50GSV-5K Netzteil eingebaut

Stromadapterkabel 1x Floppy, 2x SATA 1x SATA

Stromadapterkabel 1x Floppy, 2x SATA 1x SATA

Netzteil Rückseite, Kabelmanagement unterm Netzteil geführt

Netzteil Rückseite, Kabelmanagement unterm Netzteil geführt

Mainboard eingebaut... TPM Modul fehlt

Mainboard eingebaut… TPM Modul fehlt

Wir sehen uns beim zweiten Teil… Installation Windows Server 2016!





Amiga A600 Netzteil – Elko Wechsel

18 03 2016

Heute kam die Gelegenheit endlich um das Netzteil meines „Ratten“ Amiga A600 zu kümmern. Das Öffnen des Netzteiles ist mit Lebensgefahr verbunden. Wer nicht weiß, wo er was berühren darf, besser die Finger lassen! Nach dem Ausschalten besser das Netzteil einige Tage ausgeschaltet lassen.

Commodre A600 Netzteil. Beim Öffnen besteht Lebensgefahr!

Commodre A600 Netzteil. Beim Öffnen besteht Lebensgefahr!

Durch lösen der 4 Schrauben gelangt man an das Innere. Das Netzteil bekam eine Reinigung mit dem Brausekopf mit ständigem Wasserstrahl und schruppen einer ausgedienten Zahnbürste. Anschließend kam das Ersetzen der Elektrolytkondensatoren (Elkos) dran. Glücklicherweise war alles vorrätig im Haus. Somit war das Aus- bzw. Einlöten der Bauteile schnell erledigt. Wichtig neben der richtigen Polung ist auf die richtigen uF und Volt Werte der Bauteile zu achten. Wobei der Volt Wert auch höher liegen darf. Die heutigen Bauteile sind deutlich kleiner als die vor 20 Jahren. Auch sind auf der Platine meisten 3 Bohrungen vorhanden. Somit passen die neuen Elkos sauber ohne knicken auf die Platine. Ein Austausch wäre nun nicht zwingend notwendig gewesen. Da das Gehäuse bereits geöffnet ist… 🙂
Hier nun die Bilder:

Lite-On Netzteil

Lite-On Netzteil

Neue "Elkos" aus der Seitenansicht

Neue „Elkos“ aus der Seitenansicht

Netzteil mit neuen Elkos von oben

Netzteil mit neuen Elkos von oben

Alte Elkos in einer Reihe

Alte Elkos in einer Reihe

Zum Abschluss nun die Liste ausgelöteten Elkos:
1x 47uF, 400V
1x 3300uF, 16V
1x 2200uF, 16V
1x 1uF, 450V
1x 470uF, 16V
3x 220uF, 25V
1x 47uF, 50V
2x 1uF, 50V
1x 4,7uF, 50V

 





Verkaufe MEINEN Amiga 4000

10 02 2013

Hallo zusammen,

das Gerät steht nicht mehr zum Verkauf. Danke für die zahlreichen Anfragen und dem neuen Besitzer viel Spaß mit dem Gerät





Amiga Netzteil – Elko austausch

5 01 2012

Diese Woche hatte ich das Bedürfnis meinen Amiga 1200 raus zu kramen und ein paar Runden Banshee, Battle Squadron und Populous zu spielen. Also ausgepackt, angeschlossen und die Kiste gestartet. Der Rechner bootete normal in die Workbench und Banshee gestartet. Nach ca. 10 Minuten kam ein WHDload Fehler mit Vector Exception in $10. So ein Mist, gerade Warmgespielt und nun solch ein blöder Fehler. Also Rechner ausgeschaltet und die ganze Prozedur von vorne. Nach ca. 20 Minuten war erneut Schluss mit der gleichen Fehlermeldung. Also, irgendwas stimmt offensichtlich nicht. Denn bevor der Rechner eingepackt wurde lief dieser mit der Banshee Demo über 10 Stunden stabil. Es fand keine Änderung in der Hard- und Software statt. Als einzige Idee blieb mir nur die Spannungen zu messen. Also Multimeter heraus gezückt und am Floppystromstecker gemessen. Komischerweise lagen dort etwa nur 4,92V anstatt der benötigten 5V an. Da der Amiga für den Betrieb eigentlich nur die 5V benötigt, ersparte ich mir weitere Messungen. Es lag also eine Unterversorgung auf der 5V Schiene an und evtl. verursachte dies mein Problem mit Banshee!
Der nächste Schritt war der Blick in das Netzteil. An dieser Stelle möchte ich eine Warnung aussprechen.  Arbeiten an jeder Art von Netzteil ist gefährlich, auch wenn das Gerät einige Minuten vom Stromnetz getrennt ist, können weiterhin gefährliche Spannungen für Leib und Leben anliegen! Die Warnhinweise an Netzteilen sind nicht ohne Grund aufgedruckt und ein öffnen sollte nur von geschulten und ausgebildeten Personen erfolgen!

Sicherheitshinweis am Amiga Netzteil!

Sicherheitshinweis am Amiga Netzteil!

Nachdem das Netzteil geöffnet war schweifte mein Blick erstmals über die Kondensatoren. Bei zweien viel mir sofort der gewölbte Deckel auf. Bei diesen beiden war es nur eine Frage der Zeit bis diese mit dem Auslaufen beginnen. Ein Becher Elko läuft nur nach oben oder nach unten aus. Häufig sind es die kleinen Elkos die vom Auslaufen bedroht sind, die größeren Typen trocknen mit der Zeit innerlich aus und können somit die notwendigen Spannungen nicht liefern bzw. kommen deren Glättefunktion nicht nach.
Aufgrund des Netzteilalters entschloss ich mich für einen komplett Ersatz der Elkos. Wegen der blöden Lage der Elkos, teilweise hintereinander konnte ich die Werte nicht ablesen, also  lötete ich alle aus und markierte mir auf einem Zettel die Positionen und deren Werte. Glücklicherweise war auf der Platine der Minus-Pol mit einem schwarzen Strich markiert.

Minus Polung markiert

Minus Polung markiert

Die benötigten Typen hatte Reichelt alle auf Lager und somit folgte noch am gleichen Abend eine Bestellung. Blöd ist hier der Mindestbestellwert von 10€ Euro bei Reichelt. Für die Handvoll Elkos blieb ich unter 4 Euro. Also noch etwas Lot und PCB Reiniger mitbestellt.
Zwei Tage später klingelte der Postzusteller und übergab das überdimensionierte Paket. Oh cool, schon wieder ein Katalog drin… 🙂

Links alter Elko und rechts neuer Elko

Links alter Elko und rechts neuer Elko

Das einlöten war aufgrund der Vorarbeit ein Kinderspiel und keine große Herausforderung. Nachdem das Werk vollbracht war noch mit dem Multimeter die neu eingelöteten Bauteile durchpiepen ob sich evtl. irgendwo eine Brücke entstand.

Netzteil mit neuen Elkos bestückt

Netzteil mit neuen Elkos bestückt

War nicht der Fall und somit Deckel rauf, zugeschraubt und an den Amiga gestartet. Die Blizzard zeigte wie erwartet ihr blaues Streifenmuster und Sekunden später war die Workbench da. Nochmals am Floppystromanschluss gemessen und nun lag dort die richtige Spannung an. Also wiederum Banshee gestartet und nach ca. 3 Std. zufrieden zurückgelehnt und die Augen gerieben. Meine Güte, was flimmert der alte 1084er Monitor 😀
Das Netzteil verrichtet brav seinen Dienst und bis in 20 Jahren wenn der nächste Austausch fällig ist.