Amiga 1200 – Blizzard 1230 SCSI Kit

Hallo zusammen,
nach unzähligen Verschiebungen steht endlich das Projekt an, meinen 1993 gekauften Amiga 1200, den finalen Hardwareschliff zu verpassen.
Zuerst die Hardwarekomponenten:
– Amiga 1200 mit Kickstart 3.1
– Blizzard 1230 MK-4 mit SCSI Kit
– Acard 7720u SCSI2IDE Adapter
– Indivision AGA 1200 MK-1
– Toshiba MK2004GAL Festplatte mit 20GB

WP_20170611_15_17_51_Pro

Dem geübten Amiga Auge sticht direkt das obere Abschirmblech ins Auge. Es handelt sich hierbei um eine Modifikation die Alternate bereits bei Auslieferung des Gerätes vornahm. Ursprünglich war eine 3,5 Zoll Festplatte mit damals sagenhaften 130MB verbaut. Aufgrund der Bauweise des A1200 war eigentlich eine 2,5 Zoll Festplatte vorgesehen und Alternate entschied sich für das ausschneiden des Bleches. Damals störte mich dies wenig… heute… nur ein wenig.

Unterm Blechkleid steckt der Indivision AGA 1200 MK1 und sorgt für ein klares Bild über den VGA Ausgang am Röhrenmonitor. Mich störte bisher immer Sprunghaftigkeit der Platine aus Lisa heraus. Ein kleiner Stoß genügte und es zeichneten sich Bildstörungen am Monitor ab. Somit war der Anwender gezwungen die Platine wieder festzudrücken. Grund hierfür scheint der verbaute Sockel zu sein der trotz aller liebe und abschleifen nie 100%ig halten mochte. Eine dauerhafte Lösung musste her und wie der Zufall es wollte, nahm ich Kontakt mit dem Hersteller auf. Dieser verkaufte mir einen Sockel, wie er ebenfalls im Nachfolgeprodukt, dem Indivision 1200 AGA MK2, verbaut wurde. Somit musste wiedermal der Lötkolben bzw. die Entlötpumpe herhalten. Glücklicherweise entfällt bei mir der Handbetrieb. Gut, der Indivision hat nun den neuen Sockel und ist unter dem oberen Abschirmblechverbaut.
Außerdem liegt auf der Platine eine dünne Pappe um Kurzschlüsse zu verhindern!

WP_20170611_15_18_06_Pro

Etwas Kopfzerbrechen machte mir der Anschluss des SCSI Kits der Blizzard Turbokarte. Anders als der SCSI Standard 50 polige Anschluss hat die Karte nur einen 25 poligen Stecker.  Somit war basteln angesagt um eine Adapterkabel 26 zu 50 polig zu bauen. Die Position des ACARD Scsi2IDE Adapter war hingegen fix festgelegt. Das starre Diskettenlaufwerkkabel dient als Fixierhilfe und ein Klettband sorgt für den notwendigen halt. Ein IDE Kabel mit Stecker und Buchse sorgt als Verlängerung zum Anschluss der Festplatte. Unterhalb der Festplatte liegt ein dünner zurechtgeschnittener Karton um ein Kurzschluss zwischen Festplatte und oberes Abschirmblech zu verhindern! Die Fixierung der Festplatte erfolgte einfach mit etwas Heißkleber an der Festplatte. Heißkleber bekam hier vor den Kabelbindern den Vorzug um ein ungewolltes verrutschen der Festplatte zu verhindern. Außerdem läßt sich auch der Kleber rückstandsfrei entfernen.

Was mich am Blizzard SCSI Kit störte ist die Tatsache, dass es keine Möglichkeit gibt bzw. vorgesehen ist, die HD-Led des Amiga zu verwenden. Aufgrund des IDE Datenblattes liegt der LED Pin am PIN 39. Doch wo schließt man im Amiga nun das andere Ende an? Direkt am HD-Adapter, der Reduzierung von 44 auf 40-polig oder am Mainboard direkt? Ganz falsch, im Datenblatt des Acard 7720u ist JP3 als „Activity Led“ bezeichnet. Wie häufig im Amiga, muss gebastelt werden, so auch das Kabel mit 2 Buchsen. Doch nach dem einschalten des Amiga 1200 leuchtete die HD-Led ständig gedimmt. Hm, auf Dauer wird mir das nicht gefallen. Nach Einbau eines 10kO Widerstandes im Kabel leuchtet die HD Led auch nur beim Zugriff auf die Festplatte. Tatadada… wieder ein offener Punkt gestrichen 🙂

Dummerweise hat mein SCSI Kit noch eine ältere Version verbaut. Im vergleich zur aktuellen ROM Version 8.5 ist meine 7.19 wirklich alt. Dummerweise habe ich derzeit keine 27C256 oder 27C512 PLCC Eprom ICs hier. Daher muss das alte ROM erstmals herhalten 😀

WP_20170611_15_18_25_Pro

Damals war SCSI der quasi Standard in vielen Geräten. Heute mag die Technik angestaubt wirken, was Sie tatsächlich auch ist. Das einzig wichtige zu wissen ist:
1. der SCSI Bus muß am Ende und Anfang terminiert sein
2. jedes Gerät erhält eine unique SCSI ID

Aus diesen beiden Punkten ergibt sich beim Phase5 SCSI Kit folgende Situation. Das SCSI Kit selbst hat die ID-7. Somit stehen dem User noch die IDs 0-6 zur Verfügung. Wer mehrere Geräte in seinem A1200 unterbringen möchte, wie auch immer das funkionieren soll, vergibt die IDs aufsteigend. Also die 1. Festplatte erhälte die ID 0, das CD-ROM die ID 1 usw.
Im obigen Punkt 1 steht, das erste und letzte Gerät muss terminiert sein. Das SCSI Kit erledigt diesen Punkt bereits ohne weiteres zutun. Wichtig ist nun, den Acard als letztes Gerät meiner, zugegeben doch sehr kurzen SCSI Kette, zu terminieren. Daher muss beim 7720u der Jumper auf JP2 gesetzt sein. Wer möchte kann auch den Term-Power Jumper JP4 setzten. Beim Betrieb von einem Gerät ist dies jedoch unerheblich.
Bei SCSI-2 genügt es die passiven Terminatoren bei den Geräten zu verwenden. Nochmals, wer den SCSI Bus nicht terminiert, riskiert teilweise undefinierbare Fehler. Außerdem sucht man den Fehler überall, aber nicht in der Hardware bzw. bei einem fehlenden oder falsch gesetzten Jumper!

Hier das Datenblatte des Acard 7720U und 7720UW. Im Fall der Fälle damit es nicht irgendwann in den tiefen des Internets verschwindet.
ACARD_AEC-7720u-7720UW

Einige Bilder… und wer Fragen hat, der fragt einfach 🙂

Bis die Tage und tschüssi…

Advertisements

Reparatur Amiga 1200 – MLC RANDY ROM IDE Adapter

Am vergangenen Samstag (15.12.2012) war es wieder soweit… eine Amiga Reparatur Session. Mein Freund hatte einen MLC Randy ROM IDE Adapter falsch aufgesetzt. Dabei blieb eine IDE Reihe frei und zerstörte damit den Adapter. Die Platine selbst besteht aus einem Logik Chip (GAL 16V8), 2 Puffer ICs (SN74LS245), einem 44-pol. IDE Adapter und 2 40-pol. IDE Adapter. Viel Auswahl an Reparaturmöglichkeiten bestehen offensichtlich nicht. Nach einigem Messen stellte sich heraus, dass der 74er parallel zum GAL gelegen Probleme mit der Spannung hat. Da ich zwei neue ICs von Texas Instruments zuhause hatte bot ich an beide ICs zu tauschen. Auch wenn evtl. einer noch in Ordnung schien. Sicher ist sicher…

Bewaffnet mit Lötkolben, manuelle Entlötpumpe und Lötlitze begann ich Beinchen für Beinchen neu zu verzinnen und anschließend vom Lot freizusetzen. Es war allerdings ein richtig hartnäckiger Kampf. Selten bekam ich alles Lot frei und wechselte nach guten 10 Minuten auf die 3mm Spitze. Damit ging es deutlich besser und zügiger voran. Die Beiden 74er von Motorola waren 25 Minuten später freigelegt und ließen sich problemlos entfernen. Anschließend die neuen 74er zurechtgebogen und eingelötet. Mit dem Multimeter alles durchgemessen und das RANDY ROM am vorgeschriebenen Platz aufgesteckt. Mit Sichtkontrolle ob alle PINs richtig saßen 😉
Amiga eingeschaltet und er bootete sofort von seiner CF Karte. Mir gefällt der Adapter recht gut. Vor allem ist kein separates Kabel notwendig sondern die Platine wird direkt auf den IDE Port des Amiga aufgesteckt.

Anmerkung:
Die 3 Jumperblöcke müssen bei Kickstart 3.0 offen und bei Kickstart 3.1 geschlossen sein.
Der Sekundäre Port lässt sich nur mit der IDEfix Software verwenden. Dank IDEfix ist das RANDY ROM deutlicher fixer bei der Sache als der Standard Amiga Port.

MLC RANDY ROM IDE Adapter
MLC RANDY ROM IDE Adapter

Amiga 1200 Elko tausch

Die Elko beim Amiga scheint viele heutige Amiga User zu beschäftigen. Diese Woche meldet sich ein Amiga User der nur wenige Querstraßen von mir entfernt wohnt. Er schrieb er hätte arge Stabilitätsprobleme und ich bot ihm an am Wochenende, also heute :), bei mir vorbeizukommen.
Der erste Blick vor dem Einschalten galten den SMD Elko. Bei dem Board waren die kleinen 10uF ausgelaufen. Schön zu erkennen an den matten Stellen der beiden Lötpunkte.  Die müssen auf alle Fälle runter. Da ich nur SMD Tantals anbieten konnte und er mit dem Gerät heute Abend zocken wollte machte ich den Tausch.
Doch zuvor noch das Gerät eingeschaltet ob dieses überhaupt funktional ist. Der Rechner bootet in die Workbench. Der Sound war in Ordnung allerdings hörte man beim Red Sector Mega-Demo immer wieder Tonaussetzer. Das konnte an der verwendeten CF-Karte liegen die dort im Rechner eingebaut war. Die Mask und die Max Transfer Einstellungen entsprechen den Angaben im Internet bzw. auch denen auf der SFS Webseite für ein IDE Gerät. Daher baute ich meine Festplatte aus und dort ein. Mit meiner Festplatte gab es die Tonaussetzer nicht. Daher schieb ich das Problem auf die CF Karte. Für mich ist eine SD oder CF-Karte kein gleichwertiger Ersatz für eine Festplatte. Naja, muss jeder selbst wissen… 🙂
Der nächste Schritt war die Überprüfung des Antennen- und FBAS Anschlusses. Dort kam kein Bild, da ich wusste dass auf meinem A1200 alles ordentlich funktionierte muss es am Amiga Boards meines „Nachbarn“ liegen. Der Serielle- und Parallele Anschluss konnte ich mangels fehlenden Geräte nicht testen. Nun gut, hat heute eh kaum noch jemand 🙂

Also, dann ging es erstmals den SMD Elko an den Kragen.  Ich verwendete bisher immer Tantal. Hatte damit noch nie Probleme und wie vieles im Leben ist es eine Geschmackssache. Beim Amiga 1200 sind die verwendeten Elkos seitens Commodore bereits etwas überdimensioniert. Daher eignen sich Tantal mit der gleichen Spannungsfestigkeit wie die im Original verwendeten. Bei den Tanatals im Power-Input Bereich würde ich persönlich auf die nächst höhere Spannungsfestigkeit gehen. Wichtig hierbei ist Tantal mit dem gleichen Kapazitätswert zu verwenden analog zum Original. Das Thema ESR bzw. Low-ESR könnt Ihr beim Amiga getrost vergessen. Die billigeren Tantals von AVX bzw. Kemet genügen vollauf.
Der Tausch selbst erfolgt in 3 Schritten:

1. Das Auslöten:
Bei jedem Elko werden die beiden Beinchen mit frischem Lötzinn bestrichen. Da der Elko nachher eh in die Mülltonne wandert verwende ich eine Temperatur von 360°C. Nun kommt der Lötkolben abwechselnd an jedes Beinchen. Pro Beinchen ca. 4 Sekunden verharren und anschließend zum nächsten Beinchen hin- und her  springen. Der Elko wird nach kurzer Zeit schwammig. Vorsicht: Niemals den Elko nach oben abziehen. Sollte ein Beinchen sich nicht gelöst haben nehmt ihr evtl. das Pad mit. Daher mit dem Lötkolben immer drücken und darauf achten, den Elko immer in einen Bereich zu verschieben, in dem keine anderen Bauteile liegen. Sonst kann es passieren, dass ihr zwar den Elko von seinem Pads wegbekommt, allerdings das flüssige Lot sich mit einem anderen Bauteil verbindet. Dann kann es wiederum hässlich werden.
Bei den kleinen 10uF solltet ihr zudem aufpassen. Die Dinger können bei zu großer Hitze mit lautem Knall in die Luft gehen.

SMD Elko an C306
SMD Elko an C306
Elko an C306 ausgelötet
Elko an C306 ausgelötet

2. Das Reinigen
Nachdem der Elko runter ist die Pads vom überschüssigen Lot entfernen.
Anschließend immer nachwischen um evtl. Verschmutzungen oder ausgelaufenes Elektrolyt zu entfernen. Entweder mit Kontakt LR (Platinenreiniger) oder mit Propanol aus der Apotheke. Anschließend gut trocknen lassen. Währenddessen kann man sich dem nächsten Elko widmen 🙂

Alkohol zum Reinigen
Alkohol zum Reinigen

3. Das Einlöten
Ist bei den SMD Tantal eigentlich ganz easy. Die Pads müssen dabei vom überschüssigen Lötzinn befreit sein. Legt Euch das Board so zurecht um möglichst an beide Pads mit dem Lötkolben ohne große Verrenkungen heranzukommen. Nehmt nun ein Tantal und macht auf einer Seite einen Lötzinnklecks drauf. Achtet beim Tantal auf die richtige Polung. Der Strich ist „+“ und ist gleich der silbernen Seite beim SMD Elko! Ein falsch gepolter Tantal wird früher oder später explodieren und evtl. das Pad oder die Leiterbahn beschädigen.
Richtet den Tantal an das Ende eines Pads aus und erhitzt das Metal an der Tantal Seite. Das Lot auf der Unterseite verbindet sich nun mit dem Pad. Evtl. nochmals korrigieren und dann die gegenüberliegende Seite ganz normal anlöten. Macht Euch keinen Kopf wenn ein Tantal etwas schräg eingelötet ist. Es kommt auf die Funktion an!
Zum Einlöten genügt eine Temperatur von 320°C. Nicht länger als 3 Sekunden dranhalten und immer das Bauteil abkühlen lassen.

Tantal an C306 eingelötet
Tantal an C306 eingelötet

Teilweise ist es sinnvoll mehrere Elkos auszulöten um besser Zugang zu erhalten.

Einer nach dem anderen...
Einer nach dem anderen...

Nehmt zuerst die Becher Elko raus und wie gewohnt dann die SMD Elko. Einer nach dem anderen bis alle raus sind.

...ausgelötet und gereinigt...
...ausgelötet und gereinigt...

Nun lötet Ihr diese in genau umgekehrter Reihenfolge wieder ein. Somit kommt ihr hervorragend an die Pads ran und müsst Euch nicht um andere Bauteile kümmern.

...Tantal eingelötet.
...Tantal eingelötet.

Nach ca. 30 Minuten war alles erledigt ohne ein Pad abzureissen. Okey, sind nicht alle Tantals super schön im Winkel zur Boardaufschrift eingelötet aber alle funktionieren. Also der Amiga konnte erneut gestartet werden und tada, lief tadellos mehrere Stunden durch. Natürlich nutzen wir die Zeit um etwas Battle Squadron zu spielen 😀
Hier noch die Aufstellung der Elko und wo diese angebunden sind. Somit lässt sich bei Reparaturarbeiten schneller herausfinden ob evtl. ein kaputter Elko eine Rolle spielen könnte:

Audio Filters Right C334 22UF 
Audio Filters Left  C324 22UF  
U12 CXY1145 C214 10UF ->AUDIO_IN 
U12 CXY1145 C237 470UF -> out PIN 20 
U12 CXY1145 C236 100UF -> out PIN 20 
U12 CXY1145 C235 100UF -> out PIN 9 
U12 CXY1145 C459 22UF -> PIN 14 
Modula C239 100UF 
Video Decoupling C408 1000UF 
Video Decoupling C497 10UF 
Video Decoupling C409 100UF 
Audio Decoupling C303 22UF
Audio Decoupling C304 22UF
Audio Power (Paula) C307 470UF
Audio Power (Paula) C306 10UF
Power Input Filter C821 47UF -> 12V 
Power Input Filter C822 47UF -> -12V 
Power Input Filter C811 1000UF -> 5V 
 

Kommentare sind immer gerne gesehen. Vielen Dank und bis demnächst…